<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>A Word of Torah: All of Us Count! | The Detroit Jewish News</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://thejewishnews.com/xmlrpc.php" />
    <link rel="icon" type="image/png" href="https://thejewishnews.com/wp-content/uploads/2019/06/JN-Logo-Favicon-16x16.png"><meta name="dc.title" content="A Word of Torah: All of Us Count! — Detroit Jewish News" />
<meta name="dc.description" content="The word Naso that gives its name to this week’s parshah is a verb of an extraordinary range of meanings, among them: to lift, to carry and to forgive." />
<meta name="dc.relation" content="https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/" />
<meta name="dc.source" content="https://thejewishnews.com/" />
<meta name="dc.language" content="en_US" />
<meta name="description" content="The word Naso that gives its name to this week’s parshah is a verb of an extraordinary range of meanings, among them: to lift, to carry and to forgive." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/" />
<meta property="og:url" content="https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/" />
<meta property="og:site_name" content="The Detroit Jewish News" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="A Word of Torah: All of Us Count! — Detroit Jewish News" />
<meta property="og:description" content="The word Naso that gives its name to this week’s parshah is a verb of an extraordinary range of meanings, among them: to lift, to carry and to forgive." />
<meta property="og:image" content="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling.jpg" />
<meta property="og:image:secure_url" content="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling.jpg" />
<meta property="og:image:width" content="1080" />
<meta property="og:image:height" content="640" />
<meta property="og:image:alt" content="Baby Smiling" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="A Word of Torah: All of Us Count! — Detroit Jewish News" />
<meta name="twitter:description" content="The word Naso that gives its name to this week’s parshah is a verb of an extraordinary range of meanings, among them: to lift, to carry and to forgive." />
<meta name="twitter:image" content="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling.jpg" />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Detroit Jewish News &raquo; Feed" href="https://thejewishnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Detroit Jewish News &raquo; Comments Feed" href="https://thejewishnews.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The Detroit Jewish News &raquo; iCal Feed" href="https://thejewishnews.com/calendar/?ical=1" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.5.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-1143521-10"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thejewishnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='adsanity-default-css-css'  href='https://thejewishnews.com/wp-content/plugins/adsanity/dist/css/widget-default.css?ver=1.8.3' type='text/css' media='screen' />
<link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css'  href='https://thejewishnews.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-mini-calendar-block.min.css?ver=5.14.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://thejewishnews.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=7.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=7.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='wc-memberships-blocks-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce-memberships/assets/css/blocks/wc-memberships-blocks.min.css?ver=1.23.0' type='text/css' media='all' />
<style id='wpseopress-local-business-style-inline-css' type='text/css'>
span.wp-block-wpseopress-local-business-field{margin-right:8px}

</style>
<link rel='stylesheet' id='awsm-ead-public-css'  href='https://thejewishnews.com/wp-content/plugins/embed-any-document/css/embed-public.min.css?ver=2.7.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<style id='extendify-gutenberg-patterns-and-templates-utilities-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='media-credit-css'  href='https://thejewishnews.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='follow-up-emails-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce-follow-up-emails/templates/followups.css?ver=4.9.22' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=6.5.1' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=6.5.1' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='wc-memberships-frontend-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce-memberships/assets/css/frontend/wc-memberships-frontend.min.css?ver=1.23.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://thejewishnews.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=6ea45b81e47c58269b68289d05535e19x' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%7CLora%3A400%7CPT+Sans%3A400%7CMerriweather%3A400%7CPT+Serif%3A400%7COpen+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=11.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://thejewishnews.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='sv-wc-payment-gateway-payment-form-v5_10_12-css'  href='https://thejewishnews.com/wp-content/plugins/woocommerce-gateway-authorize-net-cim/vendor/skyverge/wc-plugin-framework/woocommerce/payment-gateway/assets/css/frontend/sv-wc-payment-gateway-payment-form.min.css?ver=5.10.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://thejewishnews.com/wp-content/themes/Newspaper/style.css?ver=11.5.1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-theme-woo-css'  href='https://thejewishnews.com/wp-content/themes/Newspaper/style-woocommerce.css?ver=11.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://thejewishnews.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=6ea45b81e47c58269b68289d05535e19x' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-woo-style-css'  href='https://thejewishnews.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_woocommerce.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://thejewishnews.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=32b0396dacab6790bdbb765eba5d6338' type='text/css' media='all' />
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/google-analytics-premium/assets/js/frontend-gtag.min.js?ver=8.5.4' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/thejewishnews.com","hash_tracking":"false","ua":"UA-1143521-10","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='fue-account-subscriptions-js-extra'>
/* <![CDATA[ */
var FUE = {"ajaxurl":"https:\/\/thejewishnews.com\/wp-admin\/admin-ajax.php","ajax_loader":"https:\/\/thejewishnews.com\/wp-content\/plugins\/woocommerce-follow-up-emails\/templates\/images\/ajax-loader.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce-follow-up-emails/templates/js/fue-account-subscriptions.js?ver=4.9.22' id='fue-account-subscriptions-js'></script>
<link rel="https://api.w.org/" href="https://thejewishnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thejewishnews.com/wp-json/wp/v2/posts/274168" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thejewishnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thejewishnews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0" />
<link rel='shortlink' href='https://thejewishnews.com/?p=274168' />
<link rel="alternate" type="application/json+oembed" href="https://thejewishnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthejewishnews.com%2F2022%2F06%2F09%2Fa-word-of-torah-all-of-us-count%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thejewishnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthejewishnews.com%2F2022%2F06%2F09%2Fa-word-of-torah-all-of-us-count%2F&#038;format=xml" />
<meta name="generator" content="Redux 4.3.14" /><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '859921007725771'); 
fbq('track', 'PageView');
</script>
<noscript>
<img height="1" width="1" 
src="https://www.facebook.com/tr?id=859921007725771&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code --><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://thejewishnews.com"><link rel="alternate" href="https://thejewishnews.com/wp-json/tribe/events/v1/" /><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"17a256eeac","wpRestUrl":"https:\/\/thejewishnews.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    
    <style id="tdb-global-colors">
        :root {--accent-color: #fff;}
    </style>
	
			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/thejewishnews.com\/wp-admin\/","wpRestNonce":"17a256eeac","wpRestUrl":"https:\/\/thejewishnews.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			    <script>
        window.tdaGlobal = {"adminUrl":"https:\/\/thejewishnews.com\/wp-admin\/","wpRestNonce":"17a256eeac","wpRestUrl":"https:\/\/thejewishnews.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","postId":274168};
    </script>
    	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

		<style type="text/css" id="wp-custom-css">
			.fl-builder-content .media-credit {
	display:none;
}		</style>
		
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #1e73be;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #1e73be;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #1e73be;
                }
                .tdm-btn-style1 {
					background-color: #1e73be;
				}
				.tdm-btn-style2:before {
				    border-color: #1e73be;
				}
				.tdm-btn-style2 {
				    color: #1e73be;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #1e73be;
                    -moz-box-shadow: 0 2px 16px #1e73be;
                    box-shadow: 0 2px 16px #1e73be;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #1e73be;
                    -moz-box-shadow: 0 4px 26px #1e73be;
                    box-shadow: 0 4px 26px #1e73be;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-274168 single-format-standard theme-Newspaper td-standard-pack woocommerce-no-js tribe-no-js tribe-bar-is-disabled tribe-theme-Newspaper a-word-of-torah-all-of-us-count global-block-template-1 single_template_2 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

            <div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background" style="visibility:hidden"></div>
<div id="td-mobile-nav" style="visibility:hidden">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/DetroitJewishNews/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/detroitjewishnews/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/JewishNewsDet" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-149798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-has-children menu-item-149798"><a href="https://thejewishnews.com/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://thejewishnews.com/category/news/international/">International</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/news/israel/">Israel</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/news/metro/">Metro Detroit</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/news/michigan/">Michigan</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/news/national/">National</a></li>
</ul>
</li>
<li id="menu-item-149804" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-149804"><a href="https://thejewishnews.com/category/arts-life/">Arts &amp; Life<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/arts-life/arts-and-entertainment/">Arts and Entertainment</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/arts-life/bridal-guide-arts-life/">Bridal Guide</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/arts-life/business/">Business</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/arts-life/fashion/">Fashion</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/arts-life/health-wellness/">Health &amp; Wellness</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/arts-life/book-nook/">JN Book Nook</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/arts-life/teen-mental-heath/">Teen Mental Heath</a></li>
</ul>
</li>
<li id="menu-item-149811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-149811"><a href="https://thejewishnews.com/category/nosh/">Nosh<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/nosh/bubbies-kitchen/">Bubbie&#8217;s Kitchen</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/nosh/danny-raskin/">Danny Raskin</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/nosh/recipes/">Recipes</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/nosh/restaurants/">Restaurants</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/nosh/sissys-kitchen/">Sissy&#8217;s Kitchen</a></li>
</ul>
</li>
<li id="menu-item-149816" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-149816"><a href="https://thejewishnews.com/category/jewish-culture/">Jewish Culture<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/jewish-culture/holidays/">Holidays</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/jewish-culture/looking-back/">Looking Back</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/jewish-culture/torah-portion/">Torah Portion</a></li>
</ul>
</li>
<li id="menu-item-149820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-149820"><a href="https://thejewishnews.com/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/opinion/columns/">Columns</a></li>
</ul>
</li>
<li id="menu-item-149822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-149822"><a href="https://thejewishnews.com/category/community/">Community<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/36-under-36/">36 Under 36</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/contests-giveaways/">Contests and Giveaways</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/faces-places/">Faces &amp; Places</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/jewishedu/">Jewish@edu</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/next-dor/">Next Dor</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/rising-stars/">Rising Stars</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/schmoozing-qas/">Schmoozing Q&amp;As</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/sports/">Sports</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/synagogue-spotlight/">Synagogue Spotlight</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/volunteer-of-the-week/">Volunteer of the Week</a></li>
	<li class="menu-item-0"><a href="https://thejewishnews.com/category/community/young-jews-making-moves/">Young Jews Making Moves</a></li>
</ul>
</li>
<li id="menu-item-274400" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-274400"><a href="https://thejewishnews.com/subscribe/">Subscribe<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-217288" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217288"><a href="https://thejewishnews.com/where-to-buy/">Where to Buy</a></li>
	<li id="menu-item-161897" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161897"><a href="https://thejewishnews.com/newsletter/">Email Newsletter Sign Up</a></li>
	<li id="menu-item-166596" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-166596"><a href="https://thejewishnews.com/subscription-services/">Subscription Customer Service</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background" style="visibility:hidden"></div>
<div class="td-search-wrap-mob" style="visibility:hidden">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://thejewishnews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 11
-->

<div class="td-header-wrap td-header-style-11 ">
    
	<div class="td-header-top-menu-full td-container-wrap td_stretch_container">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div style="visibility:hidden;">

                Friday, June 10, 2022
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-top" class="top-header-menu"><li id="menu-item-149192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-149192"><a href="https://thejewishnews.com/">Home</a></li>
<li id="menu-item-66643" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-66643"><a href="https://thejewishnews.com/about/">About</a></li>
<li id="menu-item-66645" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-66645"><a href="https://thejewishnews.com/advertise/">Advertise</a>
<ul class="sub-menu">
	<li id="menu-item-204616" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-204616"><a href="https://thejewishnews.com/advertise/classified-online-booking/">Classified Online Booking</a></li>
	<li id="menu-item-217201" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-217201"><a href="https://thejewishnews.com/advertise/advertising-terms-conditions/">Advertising Terms &#038; Conditions</a></li>
</ul>
</li>
<li id="menu-item-274395" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-274395"><a target="_blank" rel="noopener" href="https://issuu.com/detroitjewishnews">Web Edition</a></li>
<li id="menu-item-66646" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-66646"><a href="https://thejewishnews.com/lifecycle-announcements/">Announcements</a>
<ul class="sub-menu">
	<li id="menu-item-217203" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-217203"><a href="https://thejewishnews.com/lifecycle-announcements/announcement-order-form/">Announcement Order Form</a></li>
	<li id="menu-item-269062" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-269062"><a href="https://thejewishnews.com/80th-birthday-greetings/">80th Birthday Greetings</a></li>
</ul>
</li>
<li id="menu-item-230889" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-230889"><a href="https://thejewishnews.com/community-directory/">Community Directory</a></li>
<li id="menu-item-66644" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-66644"><a href="https://thejewishnews.com/contact/">Contact</a></li>
<li id="menu-item-216350" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-216350"><a href="https://thejewishnews.com/calendar/">Events</a>
<ul class="sub-menu">
	<li id="menu-item-216351" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-216351"><a href="https://thejewishnews.com/calendar/">Calendar</a></li>
	<li id="menu-item-216353" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-216353"><a href="https://thejewishnews.com/minyan-times/">Minyan Times</a></li>
	<li id="menu-item-216352" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-216352"><a href="https://thejewishnews.com/category/things-to-do/">Things to Do</a></li>
</ul>
</li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
            <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>


        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://thejewishnews.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/DetroitJewishNews/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/detroitjewishnews/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/JewishNewsDet" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap">
                    <div class="td-login-wrap">
                        <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <form id="loginForm" action="#" method="post">
                                <div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
                                <div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
                                <input type="button"  name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                                
                            </form>
                            
                            
                            
                            
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            <div class="td-login-info-text"><a class="privacy-policy-link" href="https://thejewishnews.com/privacy/">Detroit Jewish News Privacy Policy</a></div>
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <form id="forgotpassForm" action="#" method="post">
                                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
                                <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            </form>
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                		</div>
	</div>

    <div class="td-header-menu-wrap-full td-container-wrap td_stretch_container">
        
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
                <a class="td-main-logo" href="https://thejewishnews.com/">
            <img class="td-retina-data" data-retina="https://thejewishnews.com/wp-content/uploads/2021/03/tdjn-logo2x.jpg" src="https://thejewishnews.com/wp-content/uploads/2021/03/tdjn-logo2x.jpg" alt="The Detroit Jewish News" title="The Detroit Jewish News" width="544" height="111"/>
        </a>
        </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-149798"><a href="https://thejewishnews.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_1 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_1" ><script>var block_tdi_1 = new tdBlock();
block_tdi_1.id = "tdi_1";
block_tdi_1.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"1646","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_1","tdc_css_class":"tdi_1","tdc_css_class_style":"tdi_1_rand_style"}';
block_tdi_1.td_column_number = "3";
block_tdi_1.block_type = "td_block_mega_menu";
block_tdi_1.post_count = "4";
block_tdi_1.found_posts = "2748";
block_tdi_1.header_color = "";
block_tdi_1.ajax_pagination_infinite_stop = "";
block_tdi_1.max_num_pages = "687";
tdBlocksArray.push(block_tdi_1);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_1" id="tdi_2" data-td_block_id="tdi_1" data-td_filter_value="" href="https://thejewishnews.com/category/news/">All</a><a class="mega-menu-sub-cat-tdi_1"  id="tdi_3" data-td_block_id="tdi_1" data-td_filter_value="16506" href="https://thejewishnews.com/category/news/international/">International</a><a class="mega-menu-sub-cat-tdi_1"  id="tdi_4" data-td_block_id="tdi_1" data-td_filter_value="1650" href="https://thejewishnews.com/category/news/israel/">Israel</a><a class="mega-menu-sub-cat-tdi_1"  id="tdi_5" data-td_block_id="tdi_1" data-td_filter_value="1620" href="https://thejewishnews.com/category/news/metro/">Metro Detroit</a><a class="mega-menu-sub-cat-tdi_1"  id="tdi_6" data-td_block_id="tdi_1" data-td_filter_value="1648" href="https://thejewishnews.com/category/news/michigan/">Michigan</a><a class="mega-menu-sub-cat-tdi_1"  id="tdi_7" data-td_block_id="tdi_1" data-td_filter_value="1649" href="https://thejewishnews.com/category/news/national/">National</a></div></div><div id=tdi_1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/10/jewish-olympic-gold-medalist-weightlifter-isaac-ike-berger-dead-at-85/" rel="nofollow bookmark" class="td-image-wrap " title="Jewish Olympic Gold Medalist Weightlifter Isaac ‘Ike’ Berger Dead at 85" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Ike-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Ike-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Ike-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Isaac Berger" title="Jewish Olympic Gold Medalist Weightlifter Isaac ‘Ike’ Berger Dead at 85" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/10/jewish-olympic-gold-medalist-weightlifter-isaac-ike-berger-dead-at-85/" rel="bookmark" title="Jewish Olympic Gold Medalist Weightlifter Isaac ‘Ike’ Berger Dead at 85">Jewish Olympic Gold Medalist Weightlifter Isaac ‘Ike’ Berger Dead at 85</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/federations-security-program-is-now-a-standalone-organization/" rel="nofollow bookmark" class="td-image-wrap " title="Federation’s Security Program is Now a Standalone Organization" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/JCS-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/JCS-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/JCS-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Jewish Community Security Inc. (JCSI)" title="Federation’s Security Program is Now a Standalone Organization" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/federations-security-program-is-now-a-standalone-organization/" rel="bookmark" title="Federation’s Security Program is Now a Standalone Organization">Federation’s Security Program is Now a Standalone Organization</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/embracing-our-differences-se-michigan-can-be-viewed-at-parks-in-ann-arbor-and-ypsilanti/" rel="nofollow bookmark" class="td-image-wrap " title="&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in Ann Arbor and Ypsilanti" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Art-in-the-Park-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Art-in-the-Park-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Art-in-the-Park-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="“Embracing Our Differences SE Michigan” installation." title="&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in Ann Arbor and Ypsilanti" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/embracing-our-differences-se-michigan-can-be-viewed-at-parks-in-ann-arbor-and-ypsilanti/" rel="bookmark" title="&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in Ann Arbor and Ypsilanti">&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/detroits-foremost-architect-is-featured-in-new-museum-exhibit/" rel="nofollow bookmark" class="td-image-wrap " title="Detroit’s Foremost Architect is Featured in New Museum Exhibit" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Albert-Kahn-Lego-Set-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Albert-Kahn-Lego-Set-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Albert-Kahn-Lego-Set-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="A LEGO model of the Fisher Building" title="Detroit’s Foremost Architect is Featured in New Museum Exhibit" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/detroits-foremost-architect-is-featured-in-new-museum-exhibit/" rel="bookmark" title="Detroit’s Foremost Architect is Featured in New Museum Exhibit">Detroit’s Foremost Architect is Featured in New Museum Exhibit</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_1" data-td_block_id="tdi_1"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_1" data-td_block_id="tdi_1"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-149804"><a href="https://thejewishnews.com/category/arts-life/">Arts &amp; Life</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_8 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_8" ><script>var block_tdi_8 = new tdBlock();
block_tdi_8.id = "tdi_8";
block_tdi_8.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"1362","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_8","tdc_css_class":"tdi_8","tdc_css_class_style":"tdi_8_rand_style"}';
block_tdi_8.td_column_number = "3";
block_tdi_8.block_type = "td_block_mega_menu";
block_tdi_8.post_count = "4";
block_tdi_8.found_posts = "1885";
block_tdi_8.header_color = "";
block_tdi_8.ajax_pagination_infinite_stop = "";
block_tdi_8.max_num_pages = "472";
tdBlocksArray.push(block_tdi_8);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_8" id="tdi_9" data-td_block_id="tdi_8" data-td_filter_value="" href="https://thejewishnews.com/category/arts-life/">All</a><a class="mega-menu-sub-cat-tdi_8"  id="tdi_10" data-td_block_id="tdi_8" data-td_filter_value="1363" href="https://thejewishnews.com/category/arts-life/arts-and-entertainment/">Arts and Entertainment</a><a class="mega-menu-sub-cat-tdi_8"  id="tdi_11" data-td_block_id="tdi_8" data-td_filter_value="1658" href="https://thejewishnews.com/category/arts-life/bridal-guide-arts-life/">Bridal Guide</a><a class="mega-menu-sub-cat-tdi_8"  id="tdi_12" data-td_block_id="tdi_8" data-td_filter_value="16250" href="https://thejewishnews.com/category/arts-life/business/">Business</a><a class="mega-menu-sub-cat-tdi_8"  id="tdi_13" data-td_block_id="tdi_8" data-td_filter_value="1364" href="https://thejewishnews.com/category/arts-life/fashion/">Fashion</a><a class="mega-menu-sub-cat-tdi_8"  id="tdi_14" data-td_block_id="tdi_8" data-td_filter_value="1657" href="https://thejewishnews.com/category/arts-life/health-wellness/">Health &amp; Wellness</a><a class="mega-menu-sub-cat-tdi_8"  id="tdi_15" data-td_block_id="tdi_8" data-td_filter_value="21923" href="https://thejewishnews.com/category/arts-life/book-nook/">JN Book Nook</a><a class="mega-menu-sub-cat-tdi_8"  id="tdi_16" data-td_block_id="tdi_8" data-td_filter_value="1741" href="https://thejewishnews.com/category/arts-life/teen-mental-heath/">Teen Mental Heath</a></div></div><div id=tdi_8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/09/hamilton-jewish-federation-hamilton-jcc-presenting-jewish-movie-club/" rel="nofollow bookmark" class="td-image-wrap " title="Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Movie-Club-Logo-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Movie-Club-Logo-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Movie-Club-Logo-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Movie Club Logo" title="Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/09/hamilton-jewish-federation-hamilton-jcc-presenting-jewish-movie-club/" rel="bookmark" title="Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club">Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/09/great-lakes-chamber-music-festival-marks-29-years/" rel="nofollow bookmark" class="td-image-wrap " title="Great Lakes Chamber Music Festival Marks 29 Years" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Festival-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Festival-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Festival-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="A scene from last year’s festival" title="Great Lakes Chamber Music Festival Marks 29 Years" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/09/great-lakes-chamber-music-festival-marks-29-years/" rel="bookmark" title="Great Lakes Chamber Music Festival Marks 29 Years">Great Lakes Chamber Music Festival Marks 29 Years</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/embracing-our-differences-se-michigan-can-be-viewed-at-parks-in-ann-arbor-and-ypsilanti/" rel="nofollow bookmark" class="td-image-wrap " title="&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in Ann Arbor and Ypsilanti" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Art-in-the-Park-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Art-in-the-Park-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Art-in-the-Park-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="“Embracing Our Differences SE Michigan” installation." title="&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in Ann Arbor and Ypsilanti" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/embracing-our-differences-se-michigan-can-be-viewed-at-parks-in-ann-arbor-and-ypsilanti/" rel="bookmark" title="&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in Ann Arbor and Ypsilanti">&#8216;Embracing Our Differences SE Michigan&#8217; Can Be Viewed at Parks in&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/shoah-ambassadors-nominated-for-four-michigan-emmys/" rel="nofollow bookmark" class="td-image-wrap " title="&#8216;Shoah Ambassadors&#8217; Nominated for Four Michigan Emmys" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Theatre-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Theatre-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Theatre-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="A still from the documentary of Holocaust survivor Irene Miller and ambassador Hailey Callahan." title="&#8216;Shoah Ambassadors&#8217; Nominated for Four Michigan Emmys" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/shoah-ambassadors-nominated-for-four-michigan-emmys/" rel="bookmark" title="&#8216;Shoah Ambassadors&#8217; Nominated for Four Michigan Emmys">&#8216;Shoah Ambassadors&#8217; Nominated for Four Michigan Emmys</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_8" data-td_block_id="tdi_8"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_8" data-td_block_id="tdi_8"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-149811"><a href="https://thejewishnews.com/category/nosh/">Nosh</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_17 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_17" ><script>var block_tdi_17 = new tdBlock();
block_tdi_17.id = "tdi_17";
block_tdi_17.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"1380","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_17","tdc_css_class":"tdi_17","tdc_css_class_style":"tdi_17_rand_style"}';
block_tdi_17.td_column_number = "3";
block_tdi_17.block_type = "td_block_mega_menu";
block_tdi_17.post_count = "4";
block_tdi_17.found_posts = "558";
block_tdi_17.header_color = "";
block_tdi_17.ajax_pagination_infinite_stop = "";
block_tdi_17.max_num_pages = "140";
tdBlocksArray.push(block_tdi_17);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_17" id="tdi_18" data-td_block_id="tdi_17" data-td_filter_value="" href="https://thejewishnews.com/category/nosh/">All</a><a class="mega-menu-sub-cat-tdi_17"  id="tdi_19" data-td_block_id="tdi_17" data-td_filter_value="17550" href="https://thejewishnews.com/category/nosh/bubbies-kitchen/">Bubbie&#8217;s Kitchen</a><a class="mega-menu-sub-cat-tdi_17"  id="tdi_20" data-td_block_id="tdi_17" data-td_filter_value="1665" href="https://thejewishnews.com/category/nosh/danny-raskin/">Danny Raskin</a><a class="mega-menu-sub-cat-tdi_17"  id="tdi_21" data-td_block_id="tdi_17" data-td_filter_value="16509" href="https://thejewishnews.com/category/nosh/recipes/">Recipes</a><a class="mega-menu-sub-cat-tdi_17"  id="tdi_22" data-td_block_id="tdi_17" data-td_filter_value="16510" href="https://thejewishnews.com/category/nosh/restaurants/">Restaurants</a><a class="mega-menu-sub-cat-tdi_17"  id="tdi_23" data-td_block_id="tdi_17" data-td_filter_value="16511" href="https://thejewishnews.com/category/nosh/sissys-kitchen/">Sissy&#8217;s Kitchen</a></div></div><div id=tdi_17 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/03/from-the-home-kitchen-of-chef-aaron-lake-perch-dinner/" rel="nofollow bookmark" class="td-image-wrap " title="From the Home Kitchen of Chef Aaron: Lake Perch Dinner" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/05/Pan-Fried-Perch-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/05/Pan-Fried-Perch-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/05/Pan-Fried-Perch-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Lake Perch Dinner" title="From the Home Kitchen of Chef Aaron: Lake Perch Dinner" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/03/from-the-home-kitchen-of-chef-aaron-lake-perch-dinner/" rel="bookmark" title="From the Home Kitchen of Chef Aaron: Lake Perch Dinner">From the Home Kitchen of Chef Aaron: Lake Perch Dinner</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/05/26/showstopper-gourmet-ice-cream-bars-have-one-goal-to-make-people-smile/" rel="nofollow bookmark" class="td-image-wrap " title="Showstopper Gourmet Ice Cream Bars Have One Goal: To Make People Smile" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/05/Ice-Cream-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/05/Ice-Cream-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/05/Ice-Cream-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Gourmet ice cream bars" title="Showstopper Gourmet Ice Cream Bars Have One Goal: To Make People Smile" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/05/26/showstopper-gourmet-ice-cream-bars-have-one-goal-to-make-people-smile/" rel="bookmark" title="Showstopper Gourmet Ice Cream Bars Have One Goal: To Make People Smile">Showstopper Gourmet Ice Cream Bars Have One Goal: To Make People&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/05/13/from-the-home-kitchen-of-chef-aaron-heres-to-steak-and-potatoes/" rel="nofollow bookmark" class="td-image-wrap " title="From the Home Kitchen of Chef Aaron: Here’s to Steak and Potatoes" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/05/Steak-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/05/Steak-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/05/Steak-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Steak" title="From the Home Kitchen of Chef Aaron: Here’s to Steak and Potatoes" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/05/13/from-the-home-kitchen-of-chef-aaron-heres-to-steak-and-potatoes/" rel="bookmark" title="From the Home Kitchen of Chef Aaron: Here’s to Steak and Potatoes">From the Home Kitchen of Chef Aaron: Here’s to Steak and&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/04/29/soul-cafe-wants-your-input/" rel="nofollow bookmark" class="td-image-wrap " title="Soul Café Wants Your Input" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/04/Pizza-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/04/Pizza-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/04/Pizza-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Left to right: Breakfast Pizza, Taco Pizza and Summer Flat Bread." title="Soul Café Wants Your Input" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/04/29/soul-cafe-wants-your-input/" rel="bookmark" title="Soul Café Wants Your Input">Soul Café Wants Your Input</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_17" data-td_block_id="tdi_17"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_17" data-td_block_id="tdi_17"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-149816"><a href="https://thejewishnews.com/category/jewish-culture/">Jewish Culture</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_24 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_24" ><script>var block_tdi_24 = new tdBlock();
block_tdi_24.id = "tdi_24";
block_tdi_24.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"1654","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_24","tdc_css_class":"tdi_24","tdc_css_class_style":"tdi_24_rand_style"}';
block_tdi_24.td_column_number = "3";
block_tdi_24.block_type = "td_block_mega_menu";
block_tdi_24.post_count = "4";
block_tdi_24.found_posts = "1085";
block_tdi_24.header_color = "";
block_tdi_24.ajax_pagination_infinite_stop = "";
block_tdi_24.max_num_pages = "272";
tdBlocksArray.push(block_tdi_24);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_24" id="tdi_25" data-td_block_id="tdi_24" data-td_filter_value="" href="https://thejewishnews.com/category/jewish-culture/">All</a><a class="mega-menu-sub-cat-tdi_24"  id="tdi_26" data-td_block_id="tdi_24" data-td_filter_value="1660" href="https://thejewishnews.com/category/jewish-culture/holidays/">Holidays</a><a class="mega-menu-sub-cat-tdi_24"  id="tdi_27" data-td_block_id="tdi_24" data-td_filter_value="1664" href="https://thejewishnews.com/category/jewish-culture/looking-back/">Looking Back</a><a class="mega-menu-sub-cat-tdi_24"  id="tdi_28" data-td_block_id="tdi_24" data-td_filter_value="1661" href="https://thejewishnews.com/category/jewish-culture/torah-portion/">Torah Portion</a></div></div><div id=tdi_24 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/10/looking-back-remembering-the-six-day-war/" rel="nofollow bookmark" class="td-image-wrap " title="Looking Back: Remembering the Six-Day War" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Six-Day-War-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Six-Day-War-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Six-Day-War-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="From June 5-10, 1967, Israel was once again engaged in a war for survival against a coalition of Arab nations." title="Looking Back: Remembering the Six-Day War" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/10/looking-back-remembering-the-six-day-war/" rel="bookmark" title="Looking Back: Remembering the Six-Day War">Looking Back: Remembering the Six-Day War</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/" rel="nofollow bookmark" class="td-image-wrap " title="A Word of Torah: All of Us Count!" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Baby Smiling" title="A Word of Torah: All of Us Count!" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/" rel="bookmark" title="A Word of Torah: All of Us Count!">A Word of Torah: All of Us Count!</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/torah-portion-against-extremism/" rel="nofollow bookmark" class="td-image-wrap " title="Torah Portion: Against Extremism" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2020/08/torah-portion-e1584644633900-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2020/08/torah-portion-e1584644633900-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2020/08/torah-portion-e1584644633900-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Torah" title="Torah Portion: Against Extremism" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/torah-portion-against-extremism/" rel="bookmark" title="Torah Portion: Against Extremism">Torah Portion: Against Extremism</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/03/looking-back-the-all-american-hot-dog/" rel="nofollow bookmark" class="td-image-wrap " title="Looking Back: The All-American Hot Dog" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2020/07/American-Jewish-Hot-Dog-Main3-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2020/07/American-Jewish-Hot-Dog-Main3-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2020/07/American-Jewish-Hot-Dog-Main3-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Hot Dog" title="Looking Back: The All-American Hot Dog" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/03/looking-back-the-all-american-hot-dog/" rel="bookmark" title="Looking Back: The All-American Hot Dog">Looking Back: The All-American Hot Dog</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_24" data-td_block_id="tdi_24"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_24" data-td_block_id="tdi_24"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-149820"><a href="https://thejewishnews.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_29 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_29" ><script>var block_tdi_29 = new tdBlock();
block_tdi_29.id = "tdi_29";
block_tdi_29.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"1386","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_29","tdc_css_class":"tdi_29","tdc_css_class_style":"tdi_29_rand_style"}';
block_tdi_29.td_column_number = "3";
block_tdi_29.block_type = "td_block_mega_menu";
block_tdi_29.post_count = "4";
block_tdi_29.found_posts = "1352";
block_tdi_29.header_color = "";
block_tdi_29.ajax_pagination_infinite_stop = "";
block_tdi_29.max_num_pages = "338";
tdBlocksArray.push(block_tdi_29);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_29" id="tdi_30" data-td_block_id="tdi_29" data-td_filter_value="" href="https://thejewishnews.com/category/opinion/">All</a><a class="mega-menu-sub-cat-tdi_29"  id="tdi_31" data-td_block_id="tdi_29" data-td_filter_value="1663" href="https://thejewishnews.com/category/opinion/columns/">Columns</a></div></div><div id=tdi_29 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/10/guest-column-welcome-israeli-campers/" rel="nofollow bookmark" class="td-image-wrap " title="Guest Column: Welcome, Israeli Campers!" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Jamie-Bean-Photo-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Jamie-Bean-Photo-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Jamie-Bean-Photo-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Israeli campers will soon be coming to Camp Tamarack." title="Guest Column: Welcome, Israeli Campers!" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/10/guest-column-welcome-israeli-campers/" rel="bookmark" title="Guest Column: Welcome, Israeli Campers!">Guest Column: Welcome, Israeli Campers!</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/10/i-left-israel-to-give-my-kids-the-american-dream-is-this-it/" rel="nofollow bookmark" class="td-image-wrap " title="I Left Israel to Give my Kids the ‘American Dream.’ Is This It?" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Ulvade-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Ulvade-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Ulvade-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Crosses sit outside of Robb Elementary School in Uvalde, Texas, after a gunman killed 21 people inside, May 24, 2022." title="I Left Israel to Give my Kids the ‘American Dream.’ Is This It?" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/10/i-left-israel-to-give-my-kids-the-american-dream-is-this-it/" rel="bookmark" title="I Left Israel to Give my Kids the ‘American Dream.’ Is This It?">I Left Israel to Give my Kids the ‘American Dream.’ Is&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/09/what-is-a-jew-israels-renovated-diaspora-museum-attempts-a-three-story-answer/" rel="nofollow bookmark" class="td-image-wrap " title="What is a Jew? Israel’s Renovated Diaspora Museum Attempts a Three-Story Answer." ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Museum-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Museum-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Museum-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="A wall at ANU-Museum of the Jewish People in Tel Aviv honors Jewish literary greats." title="What is a Jew? Israel’s Renovated Diaspora Museum Attempts a Three-Story Answer." /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/09/what-is-a-jew-israels-renovated-diaspora-museum-attempts-a-three-story-answer/" rel="bookmark" title="What is a Jew? Israel’s Renovated Diaspora Museum Attempts a Three-Story Answer.">What is a Jew? Israel’s Renovated Diaspora Museum Attempts a Three-Story&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/students-corner-head-heart-and-hands-in-portland/" rel="nofollow bookmark" class="td-image-wrap " title="Student&#8217;s Corner: Head, Heart and Hands in Portland" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Portland-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Portland-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Portland-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Portland. Ore." title="Student&#8217;s Corner: Head, Heart and Hands in Portland" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/students-corner-head-heart-and-hands-in-portland/" rel="bookmark" title="Student&#8217;s Corner: Head, Heart and Hands in Portland">Student&#8217;s Corner: Head, Heart and Hands in Portland</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_29" data-td_block_id="tdi_29"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_29" data-td_block_id="tdi_29"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-149822"><a href="https://thejewishnews.com/category/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_32 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_32" ><script>var block_tdi_32 = new tdBlock();
block_tdi_32.id = "tdi_32";
block_tdi_32.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"67","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_32","tdc_css_class":"tdi_32","tdc_css_class_style":"tdi_32_rand_style"}';
block_tdi_32.td_column_number = "3";
block_tdi_32.block_type = "td_block_mega_menu";
block_tdi_32.post_count = "4";
block_tdi_32.found_posts = "2033";
block_tdi_32.header_color = "";
block_tdi_32.ajax_pagination_infinite_stop = "";
block_tdi_32.max_num_pages = "509";
tdBlocksArray.push(block_tdi_32);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_32" id="tdi_33" data-td_block_id="tdi_32" data-td_filter_value="" href="https://thejewishnews.com/category/community/">All</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_34" data-td_block_id="tdi_32" data-td_filter_value="16515" href="https://thejewishnews.com/category/community/36-under-36/">36 Under 36</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_35" data-td_block_id="tdi_32" data-td_filter_value="1771" href="https://thejewishnews.com/category/community/contests-giveaways/">Contests and Giveaways</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_36" data-td_block_id="tdi_32" data-td_filter_value="1667" href="https://thejewishnews.com/category/community/faces-places/">Faces &amp; Places</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_37" data-td_block_id="tdi_32" data-td_filter_value="21924" href="https://thejewishnews.com/category/community/jewishedu/">Jewish@edu</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_38" data-td_block_id="tdi_32" data-td_filter_value="25937" href="https://thejewishnews.com/category/community/next-dor/">Next Dor</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_39" data-td_block_id="tdi_32" data-td_filter_value="16514" href="https://thejewishnews.com/category/community/rising-stars/">Rising Stars</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_40" data-td_block_id="tdi_32" data-td_filter_value="16513" href="https://thejewishnews.com/category/community/schmoozing-qas/">Schmoozing Q&amp;As</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_41" data-td_block_id="tdi_32" data-td_filter_value="21431" href="https://thejewishnews.com/category/community/sports/">Sports</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_42" data-td_block_id="tdi_32" data-td_filter_value="26342" href="https://thejewishnews.com/category/community/synagogue-spotlight/">Synagogue Spotlight</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_43" data-td_block_id="tdi_32" data-td_filter_value="26343" href="https://thejewishnews.com/category/community/volunteer-of-the-week/">Volunteer of the Week</a><a class="mega-menu-sub-cat-tdi_32"  id="tdi_44" data-td_block_id="tdi_32" data-td_filter_value="17551" href="https://thejewishnews.com/category/community/young-jews-making-moves/">Young Jews Making Moves</a></div></div><div id=tdi_32 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/10/stop-and-smell-the-flowers-nextgen-detroits-blooms-brunch-program-with-goldner-walsh/" rel="nofollow bookmark" class="td-image-wrap " title="Stop and Smell the Flowers: NEXTGen Detroit’s Blooms + Brunch Program with Goldner Walsh" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Flowers-and-Bloom-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Flowers-and-Bloom-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Flowers-and-Bloom-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Ashley Nathan, Samantha Foon, Carly Schiff and Lacey Foon" title="Stop and Smell the Flowers: NEXTGen Detroit’s Blooms + Brunch Program with Goldner Walsh" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/10/stop-and-smell-the-flowers-nextgen-detroits-blooms-brunch-program-with-goldner-walsh/" rel="bookmark" title="Stop and Smell the Flowers: NEXTGen Detroit’s Blooms + Brunch Program with Goldner Walsh">Stop and Smell the Flowers: NEXTGen Detroit’s Blooms + Brunch Program&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/10/faces-places-third-annual-jvs-kadima-frame-of-mind-benefit-and-arts-showcase/" rel="nofollow bookmark" class="td-image-wrap " title="Faces &#038; Places: Third Annual JVS + Kadima Frame of Mind Benefit and Arts Showcase" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/FP-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/FP-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/FP-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Committee member Barbara Eisenberg with JVS + Kadima member Joel K" title="Faces &#038; Places: Third Annual JVS + Kadima Frame of Mind Benefit and Arts Showcase" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/10/faces-places-third-annual-jvs-kadima-frame-of-mind-benefit-and-arts-showcase/" rel="bookmark" title="Faces &#038; Places: Third Annual JVS + Kadima Frame of Mind Benefit and Arts Showcase">Faces &#038; Places: Third Annual JVS + Kadima Frame of Mind&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/09/hamilton-jewish-federation-hamilton-jcc-presenting-jewish-movie-club/" rel="nofollow bookmark" class="td-image-wrap " title="Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Movie-Club-Logo-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Movie-Club-Logo-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Movie-Club-Logo-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Movie Club Logo" title="Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/09/hamilton-jewish-federation-hamilton-jcc-presenting-jewish-movie-club/" rel="bookmark" title="Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club">Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/09/congregation-tchiyah-has-tripled-in-size-in-seven-years/" rel="nofollow bookmark" class="td-image-wrap " title="Congregation T’chiyah Has Tripled in Size in Seven Years" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Tchiyah-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Tchiyah-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Tchiyah-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Rabbi Alana Alpert on piano and Jake Ehrlich on guitar lead a musical service." title="Congregation T’chiyah Has Tripled in Size in Seven Years" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/09/congregation-tchiyah-has-tripled-in-size-in-seven-years/" rel="bookmark" title="Congregation T’chiyah Has Tripled in Size in Seven Years">Congregation T’chiyah Has Tripled in Size in Seven Years</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_32" data-td_block_id="tdi_32"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_32" data-td_block_id="tdi_32"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-274400"><a href="https://thejewishnews.com/subscribe/">Subscribe</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-217288"><a href="https://thejewishnews.com/where-to-buy/">Where to Buy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-161897"><a href="https://thejewishnews.com/newsletter/">Email Newsletter Sign Up</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-166596"><a href="https://thejewishnews.com/subscription-services/">Subscription Customer Service</a></li>
</ul>
</li>
</ul></div></div>


    <div class="td-search-wrapper">
        <div id="td-top-search">
            <!-- Search -->
            <div class="header-search-wrap">
                <div class="dropdown header-search">
                    <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                </div>
            </div>
        </div>
    </div>
            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            		<a class="td-main-logo" href="https://thejewishnews.com/">
			<img class="td-retina-data"  data-retina="https://thejewishnews.com/wp-content/uploads/2021/03/tdjn-logo2x.jpg" src="https://thejewishnews.com/wp-content/uploads/2021/03/tdjn-logo2x.jpg" alt="The Detroit Jewish News" title="The Detroit Jewish News" width="544"/>
			<span class="td-visual-hidden">The Detroit Jewish News</span>
		</a>
	        </div>
    </div>

    
</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-274168" class="post-274168 post type-post status-publish format-standard has-post-thumbnail category-jewish-culture category-torah-portion tag-a-word-of-torah tag-rabbi-lord-jonathan-sacks tag-torah-portion" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"></div>

                        <ul class="td-category"><li class="entry-category"><a  href="https://thejewishnews.com/category/jewish-culture/">Jewish Culture</a></li><li class="entry-category"><a  href="https://thejewishnews.com/category/jewish-culture/torah-portion/">Torah Portion</a></li></ul>
                        <header class="td-post-title">
                            <h1 class="entry-title">A Word of Torah: All of Us Count!</h1>

                            

                            <div class="td-module-meta-info">
                                <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://thejewishnews.com/author/jsacks/">Rabbi Lord Jonathan Sacks</a><div class="td-author-line"> - </div> </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-09T17:00:28-04:00" >06/09/2022 5:00 PM</time></span>                                <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-274168">16</span></div>                                <div class="td-post-comments"><a href="https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/#respond"><i class="td-icon-comments"></i>0</a></div>                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        

        <div class="td-post-content tagdiv-type">
            <div class="td-post-featured-image"><figure><a href="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling.jpg" data-caption="(iStock)"><img width="696" height="412" class="entry-thumb td-modal-image" src="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling-696x412.jpg" srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling-696x412.jpg 696w, https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling.jpg 1392w" sizes="(-webkit-min-device-pixel-ratio: 2) 1392px, (min-resolution: 192dpi) 1392px, 696px" alt="Baby Smiling" title="Baby Smiling"/></a><figcaption class="wp-caption-text">(iStock)</figcaption></figure></div>
            <h2>Make eye contact. Smile. Let them know you do not take them for granted. You appreciate them. They matter as individuals. For this is the life-changing idea: We are as important as we make other people feel.&#8221;</h2>
<p class="p1"><span class="s1">T</span><span class="s2">he word <i>Naso</i> that gives its name to this week’s parshah is a verb of an extraordinary range of meanings, among them: to lift, to carry and to forgive. Here though, and elsewhere in the wilderness years, it is used, in conjunction with the phrase <i>et rosh</i> (“the head”) to mean “to count.”</span></p>
<p class="p3"><span class="s2">This is an odd way of speaking, because Biblical Hebrew is not short of other verbs meaning to count, among them <i>limnot</i>, <i>lispor</i>, <i>lifkod</i> and <i>lachshov</i>. Why then not use one of these verbs? Why not simply say “count” instead of “lift the head”?</span></p>
<p class="p3"><span class="s2">The answer takes us into one of the most revolutionary of all Jewish beliefs. If we are each in the image of God, then every one of us has infinite value. We are each unique. None of us is substitutable for any other. This may well be the single most important consequence of monotheism. Discovering God, singular and alone, our ancestors discovered the human individual, singular and alone.</span></p>
<figure id="attachment_270630" aria-describedby="caption-attachment-270630" style="width: 149px" class="wp-caption alignleft"><img class="wp-image-270630" src="https://thejewishnews.com/wp-content/uploads/2022/04/Jonathan-Sacks-389x440.jpg" alt="Rabbi Lord Jonathan Sacks" width="149" height="169" srcset="https://thejewishnews.com/wp-content/uploads/2022/04/Jonathan-Sacks-389x440.jpg 389w, https://thejewishnews.com/wp-content/uploads/2022/04/Jonathan-Sacks-696x786.jpg 696w, https://thejewishnews.com/wp-content/uploads/2022/04/Jonathan-Sacks-372x420.jpg 372w, https://thejewishnews.com/wp-content/uploads/2022/04/Jonathan-Sacks-600x678.jpg 600w, https://thejewishnews.com/wp-content/uploads/2022/04/Jonathan-Sacks.jpg 716w" sizes="(max-width: 149px) 100vw, 149px" /><figcaption id="caption-attachment-270630" class="wp-caption-text">Rabbi Lord Jonathan Sacks</figcaption></figure>
<p class="p3"><span class="s2">This was simply not a value in the ancient world, nor is it one in tyrannical or totalitarian societies today. The ruler might be deemed to have infinite value; so might some of the members of his or her court; but certainly not the masses — as the word “mass” itself implies. Most people were simply regarded as part of a mass: an army, a work force or a gang of slaves. What mattered was their total number, not their individual lives, their hopes and fears, their loves and dreams.</span></p>
<p class="p3"><span class="s2">That is the image we have of Egypt of the Pharaohs. It is how the Sages understood the builders of Babel. They said that if a brick fell from the tower they wept. If a worker fell and died, they paid no attention.</span></p>
<p class="p3"><span class="s2">Almost 100 million people died in the 20th century in Stalin’s Russia, Mao’s Communist China and Cambodia under the Khmer Rouge. We say of such regimes that people became “just numbers.” That is what the Torah is rejecting as a matter of supreme religious principle.</span></p>
<p class="p3"><span class="s2">At the very moment when one might be maximally tempted to see people as “just numbers” — namely, when taking a census, as here — the Israelites were commanded to “lift people’s heads,” to raise their spirits, to make them feel they counted as individuals, not numbers in a mass, ciphers in a crowd.</span></p>
<p class="p3"><span class="s2">In the course of my life, I have had several deep conversations with Christians, and there is one aspect of Judaism that they find very difficult to understand. The conversation usually turns to the central figure of Christianity, and I am often asked, do I believe that he was the son of God.</span></p>
<p class="p3"><span class="s2">“I do indeed,” I reply, “because we believe that every Jew is a son or daughter of God.” What Christianity applies to one figure in its faith, we apply to all. Where Christianity transcendentalises, Judaism democratises. My conversation partners often think I am being evasive, finding a polite way to avoid answering the question. In fact, though, the opposite is true.</span></p>
<p class="p3"><span class="s2">The first words God commands Moses to say to Pharaoh were, “My child, My firstborn, Israel.” In </span><span class="s3"><i>Deuteronomy,</i></span><span class="s2"> Moses reminds the Israelites, “You are children of the Lord your God.” “Beloved are Israel,” said Rabbi Akiva, “for they are called God’s children.” One of the key phrases of prayer, <i>Avinu Malkenu</i>, “Our Father, our King,” encapsulates this in two simple words. We are all royalty. We are each children of the King.</span></p>
<p class="p3"><span class="s2">To be sure, this is not the only metaphor for our relationship with God. He is also our Sovereign, and we are His servants. He is our Shepherd, and we are His sheep. These evoke more humility than the image of parent-and-child. What is more, when God saw the first human without a partner, He said, “It is not good for man to be alone.”</span></p>
<h6 class="p5"><span class="s2"><b>Judaism =‘I’ + ‘We’</b></span></h6>
<p class="p2"><span class="s4">The Torah is thus signaling one of the defining tensions of all human life: we are <i>independent</i> but we are also <i>interdependent</i>. Our thoughts and feelings belong to the “I,” but much of our existence depends on being part of a “We.” Despite its unprecedented estimate of the individual, Judaism is at the same time an irreducibly communal faith. There is no “I” without the “we.”</span></p>
<p class="p3">The Chassidic master Rabbi Simcha Bunim of Przysucha nicely summed up the Jewish approach to the value of a life. He said that we should each have two pockets. In one we should place a piece of paper with the words: “For my sake was the world created.” In the other should be the words: “I am but dust and ashes.”</p>
<p class="p3"><span class="s2">We are unique. We each have non-negotiable dignity and inalienable rights. But in and of ourselves we are nothing. Our greatness comes not from us but from God. That is the dialectic of life in the conscious presence of our mortality and God’s eternity.</span></p>
<p class="p3"><span class="s2">The point being made by the Torah, though, is that<i> what matters is</i> <i>not how we see ourselves but how we see, and treat, and behave toward others. </i>The world is not short of self-important people. What it is short of is those who make <i>other people</i> feel important — who “lift their heads.”</span></p>
<p class="p3"><span class="s2">I will never forget the occasion when Prince Charles, at a banquet given by the Jewish community, spent as much time talking to the young schoolchildren who came to sing in a choir as he did to the great and good among the guests, or when he came to a Jewish primary school and lit Chanukah candles with the children, giving each the chance to tell him who they were and what the festival meant to them.</span></p>
<p class="p3"><span class="s2">That, at least in Britain, is what royalty is and does. Members of the royal family make other people feel important. That is their work, their service, their role. It is the true meaning of royalty. Watching them, you understand Rabbi Yochanan’s fine insight that “greatness is humility.” You understand also Ben Zoma’s axiom: “Who is honored? One who honors others.”</span></p>
<p class="p3"><span class="s2">The challenge that emerges from the way the Torah describes taking a census is that we must “lift people’s heads.” Never let them feel merely a number. Make those you meet feel important, especially the people whom others tend to take for granted: the waiters at a communal meal; the woman who takes your coat in a cloakroom; the shammas in the synagogue; the people doing security duty; the caretaker; the most junior member of the office team and so on.</span></p>
<p class="p3"><span class="s2">Make eye contact. Smile. Let them know you do not take them for granted. You appreciate them. They matter as individuals.</span></p>
<p class="p3"><span class="s2">For this is the life-changing idea: We are as important as we make other people feel.</span><span class="Apple-converted-space"> </span></p>
<p class="p7"><span class="s5"><i>The late </i><b><i>Rabbi Lord Jonathan Sacks </i></b><i>served as the chief rabbi of the United Hebrew Congregations of the Commonwealth, 1991-2013. His teachings have been made available to all at <a href="http://rabbisacks.org">rabbisacks.org</a>. This essay was written in 2018.</i></span></p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://thejewishnews.com/tag/a-word-of-torah/">A Word of Torah</a></li><li><a href="https://thejewishnews.com/tag/rabbi-lord-jonathan-sacks/">Rabbi Lord Jonathan Sacks</a></li><li><a href="https://thejewishnews.com/tag/torah-portion/">torah portion</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
		<style>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</style>

		<div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fthejewishnews.com%2F2022%2F06%2F09%2Fa-word-of-torah-all-of-us-count%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=A+Word+of+Torah%3A+All+of+Us+Count%21&url=https%3A%2F%2Fthejewishnews.com%2F2022%2F06%2F09%2Fa-word-of-torah-all-of-us-count%2F&via=JewishNewsDet" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/&amp;media=https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling.jpg&description=A+Word+of+Torah%3A+All+of+Us+Count%21" title="Pinterest" ><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/&title=A+Word+of+Torah%3A+All+of+Us+Count%21" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=A Word of Torah: All of Us Count!&body=https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/" title="Email" ><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://thejewishnews.com/2022/06/09/hamilton-jewish-federation-hamilton-jcc-presenting-jewish-movie-club/">Hamilton Jewish Federation, Hamilton JCC Presenting Jewish Movie Club</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://thejewishnews.com/2022/06/09/what-is-a-jew-israels-renovated-diaspora-museum-attempts-a-three-story-answer/">What is a Jew? Israel’s Renovated Diaspora Museum Attempts a Three-Story Answer.</a></div></div></div>            <div class="author-box-wrap"><a href="https://thejewishnews.com/author/jsacks/" aria-label="author-photo"><img alt='' src='https://secure.gravatar.com/avatar/9d3878045fc29bee1b75a57e16a56e7f?s=96&#038;d=identicon&#038;r=pg' srcset='https://secure.gravatar.com/avatar/9d3878045fc29bee1b75a57e16a56e7f?s=192&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://thejewishnews.com/author/jsacks/">Rabbi Lord Jonathan Sacks</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Rabbi Lord Jonathan Sacks"><meta itemprop="url" content="https://thejewishnews.com/author/jsacks/"></span><meta itemprop="datePublished" content="2022-06-09T17:00:28-04:00"><meta itemprop="dateModified" content="2022-06-07T13:15:19-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://thejewishnews.com/2022/06/09/a-word-of-torah-all-of-us-count/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://thejewishnews.com/wp-content/uploads/2021/03/tdjn-logo2x.jpg"></span><meta itemprop="name" content="The Detroit Jewish News"></span><meta itemprop="headline " content="A Word of Torah: All of Us Count!"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://thejewishnews.com/wp-content/uploads/2022/06/Baby-Smiling.jpg"><meta itemprop="width" content="1080"><meta itemprop="height" content="640"></span>        </footer>

    <div class="td_block_wrap td_block_related_posts tdi_46 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_46" ><script>var block_tdi_46 = new tdBlock();
block_tdi_46.id = "tdi_46";
block_tdi_46.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_46","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":274168,"live_filter_cur_post_author":"33393","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_46","tdc_css_class_style":"tdi_46_rand_style"}';
block_tdi_46.td_column_number = "3";
block_tdi_46.block_type = "td_block_related_posts";
block_tdi_46.post_count = "3";
block_tdi_46.found_posts = "741";
block_tdi_46.header_color = "";
block_tdi_46.ajax_pagination_infinite_stop = "";
block_tdi_46.max_num_pages = "247";
tdBlocksArray.push(block_tdi_46);
</script><h4 class="td-related-title td-block-title"><a id="tdi_47" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_46" href="#">RELATED ARTICLES</a><a id="tdi_48" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_46" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_46 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/10/looking-back-remembering-the-six-day-war/" rel="nofollow bookmark" class="td-image-wrap " title="Looking Back: Remembering the Six-Day War" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2022/06/Six-Day-War-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2022/06/Six-Day-War-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2022/06/Six-Day-War-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="From June 5-10, 1967, Israel was once again engaged in a war for survival against a coalition of Arab nations." title="Looking Back: Remembering the Six-Day War" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/10/looking-back-remembering-the-six-day-war/" rel="bookmark" title="Looking Back: Remembering the Six-Day War">Looking Back: Remembering the Six-Day War</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/08/torah-portion-against-extremism/" rel="nofollow bookmark" class="td-image-wrap " title="Torah Portion: Against Extremism" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2020/08/torah-portion-e1584644633900-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2020/08/torah-portion-e1584644633900-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2020/08/torah-portion-e1584644633900-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Torah" title="Torah Portion: Against Extremism" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/08/torah-portion-against-extremism/" rel="bookmark" title="Torah Portion: Against Extremism">Torah Portion: Against Extremism</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://thejewishnews.com/2022/06/03/looking-back-the-all-american-hot-dog/" rel="nofollow bookmark" class="td-image-wrap " title="Looking Back: The All-American Hot Dog" ><img width="218" height="150" class="entry-thumb" src="https://thejewishnews.com/wp-content/uploads/2020/07/American-Jewish-Hot-Dog-Main3-218x150.jpg"  srcset="https://thejewishnews.com/wp-content/uploads/2020/07/American-Jewish-Hot-Dog-Main3-218x150.jpg 218w, https://thejewishnews.com/wp-content/uploads/2020/07/American-Jewish-Hot-Dog-Main3-436x300.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Hot Dog" title="Looking Back: The All-American Hot Dog" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://thejewishnews.com/2022/06/03/looking-back-the-all-american-hot-dog/" rel="bookmark" title="Looking Back: The All-American Hot Dog">Looking Back: The All-American Hot Dog</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_46" data-td_block_id="tdi_46"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_46" data-td_block_id="tdi_46"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
    <div class="comments" id="comments">
            </div> <!-- /.content -->
                                    </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="td_block_template_1 widget widget_block"><div class="ad-aligncenter"><div class="ad-row">
<div id="ad-271499" class="ad-300x250 adsanity-300x250"><div class="adsanity-inner">

	<a rel="nofollow" href="https://thejewishnews.com/ads/oakland-community-college_62364/"  target="_blank"><img loading="lazy" width="300" height="250" src="https://thejewishnews.com/wp-content/uploads/2022/05/Oakland-CC_62364.jpg" class="no-lazy-load wp-post-image" alt="" /><span class="media-credit"  style="max-width: 300px">Kaitlyn Schoen | Detroit Jewish News</span></a>
</div></div>

</div><div class="ad-row">
<div id="ad-269635" class="ad-300x600 adsanity-300x600"><div class="adsanity-inner">

	<a rel="nofollow" href="https://thejewishnews.com/ads/m1-concourse-61798/"  target="_blank"><img loading="lazy" width="300" height="600" src="https://thejewishnews.com/wp-content/uploads/2022/04/M1-Concourse_61697.jpg" class="no-lazy-load wp-post-image" alt="" srcset="https://thejewishnews.com/wp-content/uploads/2022/04/M1-Concourse_61697.jpg 300w, https://thejewishnews.com/wp-content/uploads/2022/04/M1-Concourse_61697-220x440.jpg 220w, https://thejewishnews.com/wp-content/uploads/2022/04/M1-Concourse_61697-210x420.jpg 210w" sizes="(max-width: 300px) 100vw, 300px" /></a>
</div></div>

</div><div class="ad-row">
<div id="ad-229624" class="ad-300x250 adsanity-300x250"><div class="adsanity-inner">

	<a rel="nofollow" href="https://thejewishnews.com/ads/jewish-fed_58334/"  target="_blank"><img loading="lazy" width="300" height="250" src="https://thejewishnews.com/wp-content/uploads/2021/08/Jewish-Fed_58334.gif" class="no-lazy-load wp-post-image" alt="Jewish Fed_58334" /></a>
</div></div>

</div><div class="ad-row">
<div id="ad-273067" class="ad-300x250 adsanity-300x250"><div class="adsanity-inner">

	<a rel="nofollow" href="https://thejewishnews.com/ads/andiamo-bloomfield_62594/"  target="_blank"><img loading="lazy" width="300" height="250" src="https://thejewishnews.com/wp-content/uploads/2022/05/JVRG-Jewish-News_Digital-Cube-Ad.jpg" class="no-lazy-load wp-post-image" alt="" /></a>
</div></div>

</div><div class="ad-row">
<div id="ad-205479" class="ad-300x250 adsanity-300x250"><div class="adsanity-inner">

	<a rel="nofollow" href="https://thejewishnews.com/ads/djn-house-51990/"  target="_blank"><img loading="lazy" width="300" height="250" src="https://thejewishnews.com/wp-content/uploads/2020/10/DJN-House_51990.jpg" class="no-lazy-load wp-post-image" alt="" /><span class="media-credit"  style="max-width: 300px">Kelly Kosek | Detroit Jewish News</span></a>
</div></div>

</div><div class="ad-row">
<div id="ad-272009" class="ad-300x250 adsanity-300x250"><div class="adsanity-inner">

	<a rel="nofollow" href="https://thejewishnews.com/ads/mcvees-troy_62347/"  target="_blank"><img loading="lazy" width="300" height="250" src="https://thejewishnews.com/wp-content/uploads/2022/05/McVees-Troy_62347.jpg" class="no-lazy-load wp-post-image" alt="McVees Troy_62347" /></a>
</div></div>

</div></div></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>Newsletter</span></h4><div class="textwidget custom-html-widget"><!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css"/>
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://thejewishnews.us2.list-manage.com/subscribe/post?u=b6ad4ca58bacb71677eabc1b2&amp;id=28dbccefff" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<p>Stay up-to-date with the Detroit Jewish News! Subscribe to our Newsletter.</p>
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL"/>
</div>
<div class="mc-field-group">
	<label for="mce-FNAME">First Name </label>
	<input type="text" value="" name="FNAME" class="" id="mce-FNAME"/>
</div>
<div class="mc-field-group">
	<label for="mce-LNAME">Last Name </label>
	<input type="text" value="" name="LNAME" class="" id="mce-LNAME"/>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_b6ad4ca58bacb71677eabc1b2_28dbccefff" tabindex="-1" value=""/></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"/></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup--></div></aside><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Support the Detroit Jewish News Foundation</span></h4>			<div class="textwidget"><p>Support the educational mission of the independent, nonprofit Detroit Jewish News Foundation.</p>
<p><a href="https://djnfoundation.org/donate/">Donate Today!</a></p>
</div>
		</aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
        <div class="td-main-content-wrap td-footer-instagram-container td-container-wrap td_stretch_content">
			
            <div class="td-instagram-user">
                <h4 class="td-footer-instagram-title">
					Follow us on Instagram                    <a class="td-footer-instagram-user-link" href="https://www.instagram.com/detroitjewishnews" target="_blank">@detroitjewishnews</a>
                </h4>
            </div>

			<div class="td_block_wrap td_block_instagram tdi_49 td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_49" >
<style>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</style><div class="td-block-title-wrap"></div><div id=tdi_49 class="td-instagram-wrap td_block_inner td-column-1"><!-- td instagram source: instagram_cache_updated -->        <!-- header section -->
        
        <!-- user shared images -->
                        <div class="td-instagram-main td-images-on-row-6">
			                                <div class="td-instagram-element">
                            <!-- image -->
                            <a class="td-instagram-image" href="https://www.instagram.com/p/CeoIZI1uW5d/"  aria-label="instagram-image" target="_blank" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.2885-15/287179007_726886421724478_2016091040749090897_n.jpg?_nc_cat=102&ccb=1-7&_nc_sid=8ae9d6&_nc_ohc=-npsYeVcBI8AX_KOI1x&_nc_ht=scontent-iad3-1.cdninstagram.com&edm=ANo9K5cEAAAA&oh=00_AT9_67_jgSvz7IuDhXTL--_7mHKlhGoVvkPb8s9BvuPW4w&oe=62A96866)">
                            </a>
                            <!-- video icon -->
					                                        <span class="td-video-play-ico td-insta-carousel-ico">
                                    <i class="td-icon-insta-carousel"></i>
                                </span>
                                                        </div>
                        <!-- number of feeds to display -->
				                                <div class="td-instagram-element">
                            <!-- image -->
                            <a class="td-instagram-image" href="https://www.instagram.com/p/CelyG8eNCKp/"  aria-label="instagram-image" target="_blank" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.2885-15/286463921_136751098962521_2200250518783618664_n.jpg?_nc_cat=102&ccb=1-7&_nc_sid=8ae9d6&_nc_ohc=lfIOqFsEb8UAX-vvZYJ&_nc_ht=scontent-iad3-1.cdninstagram.com&edm=ANo9K5cEAAAA&oh=00_AT8kh1Yeq5av4W3bbZ5MLjo8SD5PPhAarX6n8ZovCetDpg&oe=62A7B80B)">
                            </a>
                            <!-- video icon -->
					                                </div>
                        <!-- number of feeds to display -->
				                                <div class="td-instagram-element">
                            <!-- image -->
                            <a class="td-instagram-image" href="https://www.instagram.com/p/CejAg-Puji7/"  aria-label="instagram-image" target="_blank" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.2885-15/286161754_531085595336631_5536481124396771691_n.jpg?_nc_cat=111&ccb=1-7&_nc_sid=8ae9d6&_nc_ohc=pSh9t-geCHYAX-U9eFk&_nc_ht=scontent-iad3-1.cdninstagram.com&edm=ANo9K5cEAAAA&oh=00_AT9nEC0Ib0A5lRSO5nELp7-U87vPzRpDudrw0eUJmvg56w&oe=62A955F2)">
                            </a>
                            <!-- video icon -->
					                                        <span class="td-video-play-ico td-insta-carousel-ico">
                                    <i class="td-icon-insta-carousel"></i>
                                </span>
                                                        </div>
                        <!-- number of feeds to display -->
				                                <div class="td-instagram-element">
                            <!-- image -->
                            <a class="td-instagram-image" href="https://www.instagram.com/p/CehBA8XtLTh/"  aria-label="instagram-image" target="_blank" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.2885-15/286125774_1071446033454877_2293493802486035776_n.jpg?_nc_cat=106&ccb=1-7&_nc_sid=8ae9d6&_nc_ohc=3i87qc0F5hQAX_LNILg&_nc_ht=scontent-iad3-1.cdninstagram.com&edm=ANo9K5cEAAAA&oh=00_AT-fissbdFHZlL1way9U9UFegka6WJR9DXrl2nzVeA-EOw&oe=62A89621)">
                            </a>
                            <!-- video icon -->
					                                </div>
                        <!-- number of feeds to display -->
				                                <div class="td-instagram-element">
                            <!-- image -->
                            <a class="td-instagram-image" href="https://www.instagram.com/p/CeWJGOMM8Yt/"  aria-label="instagram-image" target="_blank" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.2885-15/285403098_728104224993949_4303427493127865230_n.jpg?_nc_cat=103&ccb=1-7&_nc_sid=8ae9d6&_nc_ohc=E-pH6H-c0t0AX--z2dY&_nc_ht=scontent-iad3-1.cdninstagram.com&edm=ANo9K5cEAAAA&oh=00_AT9MtQUMeri6xvIDwQEJseIiZyO5fkH34wlgkNvTVGSa8g&oe=62A92515)">
                            </a>
                            <!-- video icon -->
					                                </div>
                        <!-- number of feeds to display -->
				                                <div class="td-instagram-element">
                            <!-- image -->
                            <a class="td-instagram-image" href="https://www.instagram.com/p/CeTwNuNO3KR/"  aria-label="instagram-image" target="_blank" style="background-image: url(https://scontent-iad3-1.cdninstagram.com/v/t51.2885-15/285874444_563061285436559_6632165850565165712_n.jpg?_nc_cat=106&ccb=1-7&_nc_sid=8ae9d6&_nc_ohc=hRBIB_remTQAX8eMKmM&_nc_ht=scontent-iad3-1.cdninstagram.com&edm=ANo9K5cEAAAA&oh=00_AT8UjkdgWYJWZ2y9OgHUP372hBJBtfKcQ1bYy1hSIFqT_A&oe=62A8AEA7)">
                            </a>
                            <!-- video icon -->
					                                        <span class="td-video-play-ico td-insta-carousel-ico">
                                    <i class="td-icon-insta-carousel"></i>
                                </span>
                                                        </div>
                        <!-- number of feeds to display -->
				                            <div class="clearfix"></div>
                </div>
		        </div></div>        </div>

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://thejewishnews.com/"><img class="td-retina-data" src="https://thejewishnews.com/wp-content/uploads/2021/03/footerlogo.png" data-retina="https://thejewishnews.com/wp-content/uploads/2021/03/footerlogo.png" alt="The Detroit Jewish News" title="The Detroit Jewish News"  width="544" height="111" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>The Detroit Jewish News is a trusted source for news, stories and opinions that affect the Metro Detroit Jewish community and beyond.<div class="footer-email-wrap">Contact us: <a href="mailto:socialmedia@thejewishnews.com">socialmedia@thejewishnews.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/DetroitJewishNews/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/detroitjewishnews/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/JewishNewsDet" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></aside></div>            </div>
        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-footer-container"><ul id="menu-footer" class="td-subfooter-menu"><li id="menu-item-66689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-66689"><a href="https://thejewishnews.com/">Home</a></li>
<li id="menu-item-66690" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-66690"><a href="https://thejewishnews.com/terms/">Terms &#038; Conditions</a></li>
<li id="menu-item-66691" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-66691"><a href="https://thejewishnews.com/privacy/">Privacy Policy</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; 2022 The Jewish News, All rights reserved. <a href="https://refineyourwebsite.com">Refine Your Website</a>                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->


		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		

    <!--

        Theme: Newspaper by tagDiv.com 2022
        Version: 11.5.1 (rara)
        Deploy mode: deploy
        
        uid: 62a3bfe9ad77b
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.td-category-description {
    width:100%;
}

.price {
    display:none;
}

.woocommerce-variation-description {
    color:red;
}

/* Image Choices */

.page-id-76 .td-page-title {
    display:none;
}




/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1141px) {
/*.showmobile {
    display:none;
}*/
}
</style>

<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script type="text/javascript">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</script><script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/js/selectWoo/selectWoo.full.min.js?ver=1.0.9-wc.6.5.1' id='selectWoo-js'></script>
<script type='text/javascript' id='wc-memberships-blocks-common-js-extra'>
/* <![CDATA[ */
var wc_memberships_blocks_common = {"keywords":{"email":"Email","phone":"Phone","plan":"Plan","address":"Address","search_not_found":"We didn\u2019t find any members. Please try a different search or check for typos.","results_not_found":"No records found..."},"ajaxUrl":"https:\/\/thejewishnews.com\/wp-admin\/admin-ajax.php","restUrl":"https:\/\/thejewishnews.com\/wp-json\/","restNonce":"17a256eeac"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce-memberships/assets/js/frontend/wc-memberships-blocks-common.min.js?ver=1.23.0' id='wc-memberships-blocks-common-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/embed-any-document/js/pdfobject.min.js?ver=2.7.1' id='awsm-ead-pdf-object-js'></script>
<script type='text/javascript' id='awsm-ead-public-js-extra'>
/* <![CDATA[ */
var eadPublic = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/embed-any-document/js/embed-public.min.js?ver=2.7.1' id='awsm-ead-public-js'></script>
<script type='text/javascript' id='fue-front-script-js-extra'>
/* <![CDATA[ */
var FUE_Front = {"is_logged_in":"","ajaxurl":"https:\/\/thejewishnews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce-follow-up-emails/templates/js/fue-front.js?ver=4.9.22' id='fue-front-script-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.6.5.1' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/thejewishnews.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=6.5.1' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.6.5.1' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=6.5.1' id='woocommerce-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_5bf8885b2e80eb2bc3a5e3caf0dc62d5","fragment_name":"wc_fragments_5bf8885b2e80eb2bc3a5e3caf0dc62d5","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=6.5.1' id='wc-cart-fragments-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce-subscriptions-gifting/js/wcs-gifting.js?ver=2.0.0' id='woocommerce_subscriptions_gifting-js'></script>
<script src='https://thejewishnews.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script src='https://thejewishnews.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=4173294bcf58591c4439ff8ccd792f1ex' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.5.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-includes/js/comment-reply.min.js?ver=6.0' id='comment-reply-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce/assets/js/jquery-payment/jquery.payment.min.js?ver=3.0.0-wc.6.5.1' id='jquery-payment-js'></script>
<script type='text/javascript' id='sv-wc-payment-gateway-payment-form-v5_10_12-js-extra'>
/* <![CDATA[ */
var sv_wc_payment_gateway_payment_form_params = {"card_number_missing":"Card number is missing","card_number_invalid":"Card number is invalid","card_number_digits_invalid":"Card number is invalid (only digits allowed)","card_number_length_invalid":"Card number is invalid (wrong length)","cvv_missing":"Card security code is missing","cvv_digits_invalid":"Card security code is invalid (only digits are allowed)","cvv_length_invalid":"Card security code is invalid (must be 3 or 4 digits)","card_exp_date_invalid":"Card expiration date is invalid","check_number_digits_invalid":"Check Number is invalid (only digits are allowed)","check_number_missing":"Check Number is missing","drivers_license_state_missing":"Drivers license state is missing","drivers_license_number_missing":"Drivers license number is missing","drivers_license_number_invalid":"Drivers license number is invalid","account_number_missing":"Account Number is missing","account_number_invalid":"Account Number is invalid (only digits are allowed)","account_number_length_invalid":"Account number is invalid (must be between 5 and 17 digits)","routing_number_missing":"Routing Number is missing","routing_number_digits_invalid":"Routing Number is invalid (only digits are allowed)","routing_number_length_invalid":"Routing number is invalid (must be 9 digits)"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce-gateway-authorize-net-cim/vendor/skyverge/wc-plugin-framework/woocommerce/payment-gateway/assets/dist/frontend/sv-wc-payment-gateway-payment-form.js?ver=5.10.12' id='sv-wc-payment-gateway-payment-form-v5_10_12-js'></script>
<script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/woocommerce-gateway-authorize-net-cim/assets/js/frontend/wc-authorize-net-cim.min.js?ver=3.7.1' id='wc-authorize-net-cim-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://thejewishnews.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=4173294bcf58591c4439ff8ccd792f1ex' id='tdb_js_files_for_front-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[274168]");
                });
            
</script>

		<script type="text/javascript">var omapi_data = {"wc_cart":{"subtotal":0,"subtotal_tax":0,"shipping_total":0,"shipping_tax":0,"shipping_taxes":[],"discount_total":0,"discount_tax":0,"cart_contents_total":0,"cart_contents_tax":0,"cart_contents_taxes":[],"fee_total":0,"fee_tax":0,"fee_taxes":[],"total":0,"total_tax":0,"cart_items":[],"currency":{"code":"USD","symbol":"&#36;","name":"United States (US) dollar"}},"object_id":274168,"object_key":"post","object_type":"post","term_ids":[1654,1661,24372,10643,1508]};</script>
		
</body>
</html>